FC4 -> FC5

剛剛看到FC5 release的消息,
馬上來嘗鮮一下把FC4給upgrade到FC5…
大概步驟如下(我選擇義守的mirror)

先檢查yum是不是最新的版本
yum –version
恩…跟現在的最新版本相同2.4.1
之後…
wget http://ftp.isu.edu.tw/pub/Linux/Fedora/linux/core/5/i386/os/Fedora/RPMS/fedora-release-5-5.noarch.rpm
rpm -Uvh fedora-release-5-5.noarch.rpm
yum update (到這他就會開始update成FC5了)

現在他還在慢慢跑…
希望沒啥問題XD
看螢幕上的log…
似乎有些mirror站還沒完全的mirror好fc5的檔案,
所以他會自己retry其他的站台…
看來是沒啥大問題才對

update:遇到問題…解決中

Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel
Error: Package kudzu needs kernel

搞定!!!
把kernel升級到kernel-2.6.15-1.1831_FC4
確定使用此kernel開機
可以使用rpm -q kernel查詢機器內有哪些kernel
我是使用簡單的rpm -e去把不相關的kernel給刪掉再reboot執行yum update,
然後把yum的repo改到義守就沒問題了
fc5
終於搞定了

參考:
http://www.fedoraproject.org/wiki/YumUpgradeFaq



留下回應